Selamat datang di matART official website!

Preview the New Matt Website (BETA)...

 
personal website :
www.rachmatonline.blogspot.com. www.ruby-warnet.com. www.matdisini.multiply.com.
Contact Us via YM :
rachmat_87@yahoo.com. matdisini@yahoo.com.
Contact Us RUBY-NET :
rubynet1@yahoo.com. rubynet2@yahoo.com. rubynet3@yahoo.com. rubynet4@yahoo.com. ruby_net_center@yahoo.com
Menu Link's
Logo
Seal online
Barner
WCG Nations
Korea Korea
Argentina Argentina
Australia Australia
Austria Austria
Belgium Belgium
Bulgaria Bulgaria
Canada Canada
Chile Chile
China
Chinese Taipei Chinese Taipei
Czech Czech Rep.
Ecuador Ecuador
France France
Germany Germany
Hong Kong China Hong Kong China
Hungary Hungary
India India
Indonesia Indonesia
Italy Italy
Japan Japan
Kazakhstan Kazakhstan
Luxembourg Luxembourg
Malaysia Malaysia
Mexico Mexico
Netherlands Netherlands
New Zealand New Zealand
Panama Panama
Peru P e r u
Philippines Philippines
Poland Poland
Portugal Portugal
Romania Romania
Russia Russia
Slovakia Slovakia
South Africa South Africa
Spain Spain
Sweden Sweden
Switzerland Switzerland
Thailand Thailand
Turkey Turkey
United Kingdom UK
Ukraine Ukraine
USA USA
Venezuela Venezuela
Vietnam Vietnam
LoadBalance + WebProxy Internal MikroTik + HOTSPOT --UPDATE--
Kamis, 21 Agustus 2008
--!!! WARNING Tested on MIKROTIK v3.10 !!!--


Yak... Udah Akang edit lagi karena ada beberapa yang perlu di "patch" tutorialnya, dan lagi-lagi seperti biasa, DILARANG COPY PASTE tanpa memberikan LINK ke Forum MikroTik, BIASAKAN HARGAI HASIL KARYA. Credit People Please......

Well, pertama mari kita selaraskan dahulu dengan tutorial Akang sebelumnya yang berada di sini Setting PPPoE 5 Speedy lalu refer per-ILMU-an dari bro Deva dan rekan forum MT disini ip firewall mangel NTH untuk load balance kemudian membaca panduan dari beliau Mr. Valens di http://wiki.mikrotik.com/wiki/MUM_2008_ID

Catatan :
1. URUTAN MENENTUKAN PRESTASI Jangan ketuker
2. Akang menggunakan 1 NIC untuk Lokal dan HotSpot (dengan sistem bypass)
3. Oleh karena dan sebab no.2, jika menemukan "HotSpot" di interface itu sama saja interface lokal.

Code:
[Akangage@[Ei-Ji].NET] /ip firewall nat
add chain=srcnat src-address=IP Lokal action=masquerade
Yang Akang bold, penting agar HotSpot juga bisa menikmati akses, kemudian jangan lupakan tutz dari bro [a], yaitu Redirect Proxy

Konfigurasi NAT + HOTSPOT

Code:
[Akangage@[Ei-Ji].NET] /ip firewall nat add chain=dstnat src-address-list="IP Lokal" protocol=tcp dst-port=80 in-interface=Interface Lokal action=redirect to-ports=8888

--> NAT u/ HotSpot <--
[Akangage@[Ei-Ji].NET] /ip firewall nat add action=redirect chain=dstnat comment="NAT Proxy HotSpot" disabled=no \
dst-port=80 hotspot=from-client,auth in-interface=HotSpot protocol=tcp \
src-address-list="IP HotSpot" to-ports=8888
Update!!!
Waspada dan patut diperhatikan, pada saat setting konfigurasi di IP HotSpot user profile, jangan di centang "transparent proxy", klient tetep bisa jalan dan terkena proxy tapi di NAT, rule tidak terkena paket.


Load Balance Versi-1
Code:
[Akangage@[Ei-Ji].NET] /ip firewall mangle
add action=mark-connection chain=prerouting comment="Load Balance" connection-state=new disabled=no in-interface=HotSpot new-connection-mark=Line-1 nth=3,1 \
passthrough=yes
add action=mark-routing chain=prerouting comment="" connection-mark=Line-1 disabled=no in-interface=HotSpot new-routing-mark=Line-1 passthrough=no
add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no in-interface=HotSpot new-connection-mark=Line-2 nth=2,1 passthrough=\
yes
add action=mark-routing chain=prerouting comment="" connection-mark=Line-2 disabled=no in-interface=HotSpot new-routing-mark=Line-2 passthrough=no
add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no in-interface=HotSpot new-connection-mark=Line-3 passthrough=yes
add action=mark-routing chain=prerouting comment="" connection-mark=Line-3 disabled=no in-interface=HotSpot new-routing-mark=Line-3 passthrough=no
Load Balance Versi-2
Code:
[Akangage@[Ei-Ji].NET] /ip firewall mangle
add action=mark-connection chain=prerouting comment="Load Balance" connection-state=new disabled=no in-interface=HotSpot new-connection-mark=Line-1 nth=3,1 \
passthrough=yes
add action=mark-routing chain=prerouting comment="" connection-mark=Line-1 disabled=no in-interface=HotSpot new-routing-mark=Line-1 passthrough=yes
add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no in-interface=HotSpot new-connection-mark=Line-2 nth=3,2 passthrough=\
yes
add action=mark-routing chain=prerouting comment="" connection-mark=Line-2 disabled=no in-interface=HotSpot new-routing-mark=Line-2 passthrough=yes
add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no in-interface=HotSpot new-connection-mark=Line-3 nth=3,3 passthrough=yes
add action=mark-routing chain=prerouting comment="" connection-mark=Line-3 disabled=no in-interface=HotSpot new-routing-mark=Line-3 passthrough=yes
Load Balance Untuk Proxy Versi-1
Code:
[Akangage@[Ei-Ji].NET] /ip firewall mangle
add action=mark-connection chain=output comment="Proxy Load Balance " connection-state=new disabled=no new-connection-mark=koneksi-proxy-1 nth=3,1 \
passthrough=yes
add action=mark-routing chain=output comment="" connection-mark=koneksi-proxy-1 disabled=no new-routing-mark=Line-1 passthrough=no
add action=mark-connection chain=output comment="" connection-state=new disabled=no new-connection-mark=koneksi-proxy-2 nth=2,1 passthrough=yes
add action=mark-routing chain=output comment="" connection-mark=koneksi-proxy-2 disabled=no new-routing-mark=Line-2 passthrough=no
add action=mark-connection chain=output comment="" connection-state=new disabled=no new-connection-mark=koneksi-proxy-3 passthrough=yes
add action=mark-routing chain=output comment="" connection-mark=koneksi-proxy-3 disabled=no new-routing-mark=Line-3 passthrough=no
Load Balance Untuk Proxy Versi-1
Code:
[Akangage@[Ei-Ji].NET] /ip firewall mangle
add action=mark-connection chain=output comment="Proxy Load Balance " connection-state=new disabled=no new-connection-mark=koneksi-proxy-1 nth=3,1 \
passthrough=yes
add action=mark-routing chain=output comment="" connection-mark=koneksi-proxy-1 disabled=no new-routing-mark=Line-1 passthrough=yes
add action=mark-connection chain=output comment="" connection-state=new disabled=no new-connection-mark=koneksi-proxy-2 nth=3,2 passthrough=yes
add action=mark-routing chain=output comment="" connection-mark=koneksi-proxy-2 disabled=no new-routing-mark=Line-2 passthrough=yes
add action=mark-connection chain=output comment="" connection-state=new disabled=no new-connection-mark=koneksi-proxy-3 nth=3,3 passthrough=yes
add action=mark-routing chain=output comment="" connection-mark=koneksi-proxy-3 disabled=no new-routing-mark=Line-3 passthrough=yes
Mangle untuk Queue
Code:
[Akangage@[Ei-Ji].NET] /ip firewall mangle
add action=mark-connection chain=prerouting comment="Mangle for Queue" disabled=no new-connection-mark=koneksi-klien passthrough=yes src-address=\
[b]IP Lokal[/ip]
add action=mark-packet chain=prerouting comment="" connection-mark=koneksi-klien disabled=no in-interface=HotSpot new-packet-mark=paket-upload passthrough=no
add action=mark-packet chain=prerouting comment="" connection-mark=koneksi-klien disabled=no new-packet-mark=paket-download passthrough=no
add action=mark-packet chain=output comment="" connection-mark=koneksi-klien disabled=no dscp=4 new-packet-mark=paket-hit-download out-interface=HotSpot \
passthrough=no
add action=mark-packet chain=output comment="" connection-mark=koneksi-klien disabled=no new-packet-mark=paket-download out-interface=HotSpot passthrough=no
Code:
[Akangage@[Ei-Ji].NET] /ip route
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=ADSL-1 \
routing-mark=Line-1
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=ADSL-2 \
routing-mark=Line-2
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=ADSL-3 \
routing-mark=Line-3
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=ADSL-1
Setelah sukses route jangan sampai kelupaan, ntar ga bisa jalan internetnya yaitu disini...

Code:
[Akangage@[Ei-Ji].NET] /ip proxy
set always-from-cache=yes cache-administrator=Akangage@ei-ji.net cache-drive=system cache-hit-dscp=4 cache-on-disk=yes enabled=yes max-cache-size=unlimited \
max-client-connections=600 max-fresh-time=3d max-server-connections=600 parent-proxy=0.0.0.0 parent-proxy-port=0 port=8888 serialize-connections=no \
src-address=0.0.0.0
NOTES : Baca TELITI Jangan TERBURU NAPSU

Nah.... setelah semua itu beres, silahkan di tes dan di-uji-coba kan, sory no pics untuk Tutz... sengaja biar akal sehat temen2 MT disini jalan semua dan tidak sembarang Copy Paste tanpa refer back ke ForumMikrotik. Akang lampirkan hasil-nya saja yah...

This image has been resized. Click this bar to view the full image. The original image is sized 799x637.


This image has been resized. Click this bar to view the full image. The original image is sized 799x670.


This image has been resized. Click this bar to view the full image. The original image is sized 799x300.


This image has been resized. Click this bar to view the full image. The original image is sized 799x456.





---------------------------------------------------------------------------------------
Mari kita budayakan "Thanks" atas setiap jernih payah usaha seseorang agar lebih semangat
lagi dalam mencari ilmu yang baru...... jangan lupa klik "Thanks"
---------------------------------------------------------------------------------------
posted by Matt! @ 04.44  
1 Comments:
  • At 29 November 2008 pukul 06.24, Anonymous Anonim said…

    khusus akanggage thanks banyak, dan om rahmat juga.

    saat ini load saya sudah berfungsi tapi belum maksimal. kira2 untuk mengoptimalkan load bagaimana yah.

    Mohon pencerahan

    Thanks
    Kangdidin (newbeee)

     
Posting Komentar
<< Home
 
About Me

Name: Matt!
Home: Bandung, Indonesia, Indonesia
About Me: lo mau tau gw? ketik reg matt kirim sms ke 022-91272766 sms yang lo dapet langsung dari hp gw! hehehehe..
See my complete profile
Previous Post
Archives
Partner!
Jam berapa sekarang?
Chit Chat!
© 2006 Selamat datang di matART official website! .Template by Preview the New Matt Website (BETA)